通告 欢迎访问爱刷机(原爱搜路由、爱搜啊博客aisoa.cn)

如何在OpenWRT上开个双wan叠加带宽使用OpenWRT开启多线多拨外加Mac地址克隆

2021-06-21
0评论
/
阅读
管理员

前一段时间有朋友在落格发过几个OpenWRT的系列教程,讲了一些OP的高级用法,当然了,这方面我就略输一筹了。不过,最近由于宿舍网络质量太差(主要是没有QoS让人烦恼)所以我就又翻出了我箱子底下吃灰的那个rg100a-aa,可怜的家伙当时还没有什么该内存一说,我的还只是可怜的30M。

不过没关系,尽管内存小了些,OP 的QoS渣了些,但至少有啊,这时候就有点还念当年那个SOHO级的思科100,可惜让我一百五给卖了。

由于实际需要,我这里写一写如何使用OP来开启双线双拨。

使用插件一键开多拨总会出现各种各样的问题,所以,路由还是推荐大家使用ssh上去,通过CLI来配置你的路由器哦。

好了,闲话少说,我们开干。

OpenWRT开启多线多拨mwan3

环境

首先说说我的网络环境,由于快要毕业了,好多同学都已经去实习了,宿舍就我和哥们两人,而网没有到期的还有两根,都是10M电信pppoe;

手头刚好有个rg100a,刷好了OP,找了个比较新的包凑合了,用来做QoS和负载均衡。

刷机

我这个买的时候当时就是刷好的OP,当然了,rg100a也刷不了别的包,我从网上找了好久,找到了两个比较好用的包,一个功能齐全比较旧,一个是比较新的适合自定义——等我有空了,就试试自己来编译个更好的包给大家。

 2013.5.22更新RG100A_DB120固件,增加NTFS自动挂载、开启共享写..

2014年10月10日 发DB120/RG100,HG255D,703,720,741,841版本固件. 不带CFE

下载好直刷包就在web配置页面直接上传刷机就好了,刷好了等待重启就OK。

这两个包我我就不放在这里了,一方面是太大不好上传,另一方面免得说我盗窃什么的。我就放上它们各自的论坛页面链接好了。

1、划分VLAN

要配置多线多拨,光会划分VLAN是不够的,还需要虚拟网卡。一开始我也以为只要多划分个VLAN给另外一个网口就好了,但事实证明这样的做法是错误的。当然了第一个wan口还是需要VLAN的,你需要按照正常上网划分的VLAN那样来划分。

root@OpenWrt:~# cat /etc/config/network
 
config switch 'eth1'
option reset '1'
option enable_vlan '1'
option enable '1'
 
config switch_vlan
option device 'eth1'
option vlan '0'
option ports '1 2 3 5' 
//注意看你机器的命令格式,可能稍有不同,
//你要根据情况来稍加改动
config switch_vlan
option device 'eth1'
option vlan '1'
option ports '0 5'
 
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
 
config interface 'lan'
option type 'bridge'
option ifname 'eth1.0'
option proto 'static'
option ipaddr '192.168.2.1'
option netmask '255.255.255.0'
option nat '1'

2、虚拟网卡

虚拟出第二块网卡来添加另一个wan拨号。

你可以在web界面配置,也可以在CLI来配置,反正命令是一样的。

使用web页面编辑rc.local文件

如果使用CLI,则内容是这样的,我也贴出来,方便你复制。

root@OpenWrt:~# cat /etc/rc.local
# Put your custom commands here that should be executed once
# the system init finished. By default this file does nothing.
 
ip link add link br-lan eth2 type macvlan
ifconfig eth2 hw ether 36:37:38:39:40:50
ifconfig eth2 up

根据你网卡的序号,添加另外的一块网卡名为eth2,然后给它一个任意不同的MAC地址并且默认启动。

3、添加wan口

重启路由器时命令生效后我们就可以来添加wan口了,一个是默认的,另一个是我们使用虚拟网卡添加的。注意看命令,找到要编辑的文件,在里边追加命令:

root@OpenWrt:~# cat /etc/config/network
//其他内容略
config interface 'wan'
 option ifname 'eth1.1'
 option _orig_ifname 'eth1.1'
 option _orig_bridge 'false'
 option macaddr '给一个任意不同的mac地址注意要小写'
 option proto 'pppoe'//选择协议为pppoe,下同
 option password '宽带密码'
 option username '宽带地址'
 
config interface 'wan100'
 option ifname 'eth2'
 option proto 'pppoe'
 option password '宽带密码'
 option username '宽带地址'

4、防火墙配置

配置好了wan口还是不够的,除了默认的wan,你还需要把多出来的wan100加入wan区域,否则一样无法实现双wan。

这一步你可以在web页面通过编辑wan100接口属性中的“防火墙”部分来直接指定为“wan”,或者也可以一口气在CLI上直接完成,下面是修改位置

root@OpenWrt:~# cat /etc/config/firewall
config zone
option name 'wan'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'
//注意下边这句,将wan100加入其中。
option network 'wan wan100'
//上下其他内容略……

5、插线

这样,两个wan口就配置好了。其中你默认的wan口插一个网线,配置好pppoe账号密码,另外一个外网的网线插入lan口的任意口即可,也配置好pppoe的账号密码,这样两根线就已经能够同时拨通了,当然,可能你在系统状态页面只能看到一个。

6、负载均衡

这里就不再多做介绍,路由使用的是N-wan这个软件,勾选开启就好了,不过要记得自己重新添加wan口信息才行,名字要写对。

7、QoS

OP上的QoS确实渣的一逼,但聊胜于无嘛,路由使用的是比较著名的emong‘s QoS,有没有效是不是心理作用这个也看不出来,反正记得看清单位,一般应该是kbit,其实是千比特。

这个很好理解,它恰好对应着你的带宽而不是速度,比如你是1M的带宽,那就是1024kbit了,10M,就是10240kbit。


本站附件分享,如果附件失效,可以去找找看

诚通网盘附件百度网盘附件


标签: OpenWRT mwan3
于2021-06-21发布